Back to overview
Resolved

no shares in window

May 30, 2026 at 9:40pm UTC
Affected services
Active Shares

Resolved
May 31, 2026 at 8:00am UTC

resolved

Created
May 30, 2026 at 9:40pm UTC

downtime